$re = '/(?i)((https?:\/\/|www\.)(?!.*(fnac\.fr|amazon\.com|actu\.fr|youtube\.com\/watch\?.*v=|youtu\.be\/)).+)|(\w+\.\w+)$/m';
$str = 'je t\'aime www.fnac.fr
www.amazon.com
https://test1.amazon.com
https://www.amazon.fr/sasa
http://url.actu.fr/b9af4a14
www.google.fr
www.lol.com
hi voila.fr
Utilisons WhatsApp, une application rapide, simple et sécurisée pour envoyer des messages et appeler gratuitement. À télécharger sur https://whatsapp.com/dl/lol
https://www.youtube.com/watch?v=dvPYQHLZdUk
Https://youtu.be/NLPyySN9Czw?si=nnOgbaHgZSeBHA6U
CrazyCat ça va?
lol comment tu vas
WWW.GOOGLE.FR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);