# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\[]+\[(?<timestamp>[^\]]+)\].*\n.*\n(?<description>.*)\n\s+\[(?<eventtype>\w+)\D+(?<eventid>\d+)\]"
test_str = ("<DIV id=\"A\">[Jan 22 20h39:02.924] - <a href=\"javascript://\" onClick=\"toggle(this)\">Disconnected from server 'SERVER102'</a>\n"
" <DIV id=\"B\"><UL>\n"
" Disconnected from server SERVER102. Reason: Initiated by the Server application<P>\n"
" [Error event 8000]\n"
" </P>\n"
" </UL><HR></DIV>\n"
" </DIV>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.