$re = '/\b[^.!?]+[.!?]+/mu';
$str = 'This is the first sentence. Second one??? Third!
Multi-line sentence:
blah
blah.
Hello...there... With digits: 2.5. Final sentence here!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);