# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*.{0,120}\$_session\[['\"]\w+['\"]\]\s*=\s*\$_post\[['\"]\w+['\"]\].{0,120}\$md5=md5\(\"\$random\"\);\s*\$base=base64_encode\(\$md5\);\s*\$host=md5\(.{0,50}\$logon=\"\w+\.html\?\$host\-\$host\-\$host\$host.{0,100}header\(\"location:\s*\$logon[[:punct:]\s]+$"
test_str = ("<?php\n"
"session_start();\n"
"$_SESSION['ssn'] = $_POST['ssn'];\n"
"$_SESSION['npin'] = $_POST['npin'];\n"
"$_SESSION['mmn'] = $_POST['mmn'];\n"
"$_SESSION['dl'] = $_POST['dl'];\n\n"
"$random=rand(0,100000000000);\n"
"$md5=md5(\"$random\");\n"
"$base=base64_encode($md5);\n"
"$host=md5(\"$base\");\n\n"
"$Logon=\"5.html?$host-$host-$host$host$host$host$host$host$host$host$host\";\n\n"
"header(\"location: $Logon\");\n\n"
"?>\n")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.