$re = '/(@?\w+)((?:\s+|\W))/m';
$str = 'this is a test, of proper nouns @Ryan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);