$re = '/^(^\#.\#)/m';
$str = '#1#http://test.ir:8080/srvSC.svc#1#
#2#http://test.ir:8081/srvSC.svc#2#
#3#http://test.ir:8082/srvSC.svc#3#
#4#http://test.ir:8083/srvSC.svc#4#
#5#http://test.ir:8084/srvSC.svc#5#
#6#http://test.ir:8085/srvSC.svc#6#
#7#http://test.ir:8086/srvSC.svc#7#
#8#http://test.ir:8087/srvSC.svc#8#
#9#http://test.ir:8088/srvSC.svc#9#
#10#http://test.ir:8089/srvSC.svc#10#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);