import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#\\d+#)(.+)\\1$";
final String string = "#1#http://test.ir:8080/srvSC.svc#1#\n"
+ "#2#http://test.ir:8081/srvSC.svc#2#\n"
+ "#3#http://test.ir:8082/srvSC.svc#3#\n"
+ "#4#http://test.ir:8083/srvSC.svc#4#\n"
+ "#5#http://test.ir:8084/srvSC.svc#5#\n"
+ "#6#http://test.ir:8085/srvSC.svc#6#\n"
+ "#7#http://test.ir:8086/srvSC.svc#7#\n"
+ "#8#http://test.ir:8087/srvSC.svc#8#\n"
+ "#9#http://test.ir:8088/srvSC.svc#9#\n"
+ "#10#http://test.ir:8089/srvSC.svc#10#\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}