#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#\d+#"
Local $sString = "#1#http://test.ir:8080/srvSC.svc#1#" & @CRLF & _
"#2#http://test.ir:8081/srvSC.svc#2#" & @CRLF & _
"#3#http://test.ir:8082/srvSC.svc#3#" & @CRLF & _
"#4#http://test.ir:8083/srvSC.svc#4#" & @CRLF & _
"#5#http://test.ir:8084/srvSC.svc#5#" & @CRLF & _
"#6#http://test.ir:8085/srvSC.svc#6#" & @CRLF & _
"#7#http://test.ir:8086/srvSC.svc#7#" & @CRLF & _
"#8#http://test.ir:8087/srvSC.svc#8#" & @CRLF & _
"#9#http://test.ir:8088/srvSC.svc#9#" & @CRLF & _
"#10#http://test.ir:8089/srvSC.svc#10# " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")