import Foundation
let pattern = #"(?<freecall_7digitspecial>^180[ |-]{0,1}2[ |-]{0,1}[0-9]{1}[ |-]{0,1}[0-9]{2}$)|(?<freeANDlocalrate_3grouping_std>^1800|1300[ |-]{0,1}[0-9]{3}[ |-]{0,1}[0-9]{3}$)|(?<freeANDlocalrate_2grouping_std>^1800|1300[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}$)|(?<localrate_6digitspecial>^13[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}$)|(?<landlineGeoNSW_4grouping_8digit>^[1-9]{1}[0-9]{3}[ |-]{0,1}[0-9]{4}$)|(?<landlineGeoAreaCode_10digit>^0[2|3|7|8][ |-]{0,1}[0-9]{4}[ |-]{0,1}[0-9]{4}$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234-5678"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)