const regex = /errorCode\s*\=\s*\\\"(?<errorCode>[^\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('errorCode\\s*\\=\\s*\\\\\\"(?<errorCode>[^\\\\]+)', 'gm')
const str = `{"stream":"stderr","logtag":"P","log":"10/May/2024:09:31:53 +1000 [dgbttrfr] [correlationId=] [subject=], ERROR au.com.jbjcbdj.o.fefewgr.logging.LoggingUtil - severity = \\"ERROR\\", DateTimestamp = \\"09/May/2024 23:31:53\\", errorCode = \\"PAY_STAT_ERR_0017\\", errorMessage = \\"Not able to fetch error\\","hostname":"ip-101-156-185.ap-southeast-2.internal","host_ip":"10.56","cluster":"nod/pmn08"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}