package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w*?[dD]ate\w*?\b`)
var str = `Expected_Start_DateTime,Metrics_Count,Device_UID,Command_Name,Command_Interval,Start_DateTime,Instance_UID,Execution_Date,Metrics_Size_KB,End_DateTime,Tags_Countfrom command_execution`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}