re = /^,*|,*$/m
str = ',Metrics_Count,Device_UID,Command_Name,Command_Interval,,Instance_UID,,Metrics_Size_KB,,Tags_Countfrom command_execution,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end