const regex = /\balmdrasa\b\s+\b\w{3,}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\balmdrasa\\b\\s+\\b\\w{3,}\\b', 'gm')
const str = `almdrasa is your way to learn programming the right way. almdrasa badges motivate students to do more. almdrasa quizes help students practice on what they have learned through the course. almdrasa courses are one of a kind because they were made by professionals. almdrasa look and feel is one of a kind. almdrasa wishes you a good learning. thanks.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}