re = /^(?=(\/)(?:.*\1){1,}).*/m
str = 'test -> false
/test -> false
/test/test -> true
/test/test/test -> true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end