re = /(["'])((?:(?:\\\1)|[^\1])*?)\1/m
str = 'fdlfksj "hello1" dsffsf "hello2\\"hi" name("Tod") \'hello3\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end