import re
regex = re.compile(r"[ \d](?:(?<=[ ])[ ]|\d){7}\d", flags=re.MULTILINE)
test_str = ("123456789\n"
"kfasdf 3456789asdf\n"
"a 1\n"
" << spaces\n"
"12345 789\n"
"1 9\n"
"a 678a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")