$re = '/^Master\/Slave Set:\s(.*?\s)\[(.*)\]\sMasters:\s\[\s(.*)\s\]\s(Slaves:\s\[\s(.*)\s\])?/m';
$str = 'Cluster name: tripleo_cluster
Stack: corosync
Current DC: rlpclay1ct1003 (version 1.1.18-11.el7_5.3-2b07d5c5a9) - partition with quorum
Last updated: Thu Oct 18 16:37:49 2018
Last change: Tue Oct 16 14:28:04 2018 by hacluster via crmd on rlpclay1ct1002
3 nodes configured
22 resources configured
Online: [ rlpclay1ct1001 rlpclay1ct1002 rlpclay1ct1003 ]
Offline: [ partb ]
Full list of resources:
ip-172.31.2.109 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1002
Clone Set: haproxy-clone [haproxy]
Started: [ rlpclay1ct1001 rlpclay1ct1002 rlpclay1ct1003 ]
Master/Slave Set: galera-master [galera]
Masters: [ rlpclay1ct1001 rlpclay1ct1002 rlpclay1ct1003 ]
ip-172.31.8.16 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1003
ip-172.31.0.19 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1002
ip-172.31.4.106 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1003
Clone Set: rabbitmq-clone [rabbitmq]
Started: [ rlpclay1ct1001 rlpclay1ct1002 rlpclay1ct1003 ]
Master/Slave Set: redis-master [redis]
Masters: [ rlpclay1ct1003 ]
Slaves: [ rlpclay1ct1001 rlpclay1ct1002 ]
ip-172.31.8.19 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1002
ip-10.195.128.10 (ocf::heartbeat:IPaddr2): Started rlpclay1ct1003
openstack-cinder-volume (systemd:openstack-cinder-volume): Started rlpclay1ct1002
my-ipmilan-for-controller0 (stonith:fence_ipmilan): Started rlpclay1ct1001
my-ipmilan-for-controller1 (stonith:fence_ipmilan): Started rlpclay1ct1001
my-ipmilan-for-controller2 (stonith:fence_ipmilan): Started rlpclay1ct1001
Daemon Status:
corosync: active/enabled
pacemaker: active/enabled
pcsd: active/enabled
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);