$re = '/^(?=(.*[0-9]))((?=.*[A-Za-z0-9])(?=.*[A-Z])(?=.*[a-z]))^.{8,}$/m';
$str = 'pass
123456
pa$sword
passWord1
paSWord@111
mYpa$$word123
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);