re = /([+a-zA-Z0-9._-]+@[a-zA-Z0-9._-]+\.[a-zA-Z0-9_-]+)/i
str = 'This is a test.email@domain.com.
This is another label-specific email: hello+website@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end