$re = '/,(?=(?:(?!,).)*=)/m';
$str = 'key1=a,b,c,key2=def,key3=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);