import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<numberExpression>(?<numberDice>[0-9]+)(?<gaussExpression>[oO]?(?<gaussDices>[0-9])+(?<gaussModifier>[\\+\\-])?)?)?[dD](?<faces>[0-9]+)(?<exploding>[¡!]{0,2})(?<modifierExpression>[\\+\\-](?<modifierValue>[0-9]+))?(?<thresholdExp>:(?<thresholdValue>[0-9]+))?";
final String string = "Common dice:\n"
+ "1d2 (coin flip)\n"
+ "2d4\n"
+ "3d6\n"
+ "4d8\n"
+ "5d10\n"
+ "6d12\n"
+ "7d20\n"
+ "8d30\n"
+ "9d100\n\n"
+ "Gauss notation:\n"
+ "1o3d10 Basic notation\n"
+ "1o3+d10 Gauss with gauss-modifier\n"
+ "1o3-d10 Gauss with gauss-modifier\n"
+ "1o5d8 Gauss with other configurations\n\n"
+ "Exploding dice:\n"
+ "1d10! Exploding\n"
+ "1d10¡ Imploding\n"
+ "1d10!¡ Both, exploding and imploding\n"
+ "1d10¡! Another possible arrangement\n"
+ "1o3d10! Gauss exploding\n\n"
+ "Adding and substracting:\n"
+ "1d10+20\n"
+ "1d10-3 \n"
+ "1o3d10+3 Gauss with modifiers\n"
+ "1o3d10!-3 Gauss with exploding dice and modifiers\n\n"
+ "Threshold:\n"
+ "1d10:6\n"
+ "1d10+2:8 Modifier and threshold\n"
+ "1d10!+1:8 Exploding, modifier and threshold\n"
+ "1o3+d10!+3:8 Gauss with gauss-modifier, exploding option, modifier and threshold";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}