import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\d*\\s*(\\S*)\\s*\\d*\\s*\\d*\\s*\\$\\d*\\.\\d*\\s*\\d\\.\\d*(.*)";
final String string = " 269299 clickadu.com 0 0 $0.00051 1.8 46,924 $24.08 0 $0.00 0.00% \n\n"
+ " 298822 pr.vespymedia.com 0 0 $0.00051 1.2 27,265 $14.02 0 $0.00 0.00% \n\n"
+ " 286365 adpalladium.com 0 0 $0.00052 1.2 26,728 $13.77 0 $0.00 0.00% \n\n"
+ " 229090 vertoz.com 0 0 $0.00051 1.3 22,394 $11.46 0 $0.00 0.00% \n\n"
+ " 283296 mediaconvers.com 0 0 $0.00051 1.2 19,597 $10.02 0 $0.00 0.00% \n\n"
+ " 286321 eximdigital.com 0 0 $0.00051 1.4 12,801 $6.52 0 $0.00 0.00% \n\n"
+ " 303567 xxxkiwi.com 0 0 $0.00051 2.2 12,266 $6.25 0 $0.00 0.00% \n\n"
+ " 270662 ero-advertising.com 0 0 $0.00052 1.4 9,799 $5.05 0 $0.00 0.00% \n\n"
+ " 274097 theinterracialxxx.com 0 0 $0.00051 2.8 8,777 $4.47 0 $0.00 0.00% \n\n"
+ " 274091 hugestrapon.net 0 0 $0.00051 2.6 8,617 $4.38 0 $0.00 0.00% \n\n"
+ " 303918 naughtysiblings.com 0 0 $0.00051 2.8 7,701 $3.92 0 $0.00 0.00% \n\n"
+ " 305427 news.zhekapty.com 0 0 $0.00051 4.0 7,119 $3.65 0 $0.00 0.00% \n\n"
+ " 279543 zhekapty.com 0 0 $0.00051 4.0 6,939 $3.56 0 $0.00 0.00% \n\n"
+ " 270845 cruelstraponwife.com 0 0 $0.00051 2.9 6,793 $3.47 0 $0.00 0.00% \n\n"
+ " 266012 arabfuck.info 0 0 $0.00051 3.4 6,217 $3.17 0 $0.00 0.00% \n\n"
+ " 244057 14027.pr.com 0 0 $0.00051 3.1 5,842 $2.98 0 $0.00 0.00% \n\n"
+ " 303031 app.eximdigital.com 0 0 $0.00051 1.2 5,666 $2.88 0 $0.00 0.00% \n\n"
+ " 278481 japanporn.info 0 0 $0.00051 2.5 5,602 $2.86 0 $0.00 0.00% \n\n"
+ " 289627 publicbeachporn.info 0 0 $0.00051 2.5 5,204 $2.65 0 $0.00 0.00% \n\n"
+ " 301818 real-girls.exposed 0 0 $0.00051 2.5 4,646 $2.36 0 $0.00 0.00% \n\n"
+ " 16307 popcash.net 0 0 $0.00051 1.6 4,448 $2.29 0 $0.00 0.00% \n\n"
+ " 284508 anallovers.info 0 0 $0.00051 2.6 4,482 $2.28 0 $0.00 0.00% \n\n"
+ " 278560 latinanudegirls.info 0 0 $0.00051 2.5 4,384 $2.23 0 $0.00 0.00% \n\n"
+ " 300712 ganzgeilxxx.com 0 0 $0.00051 2.4 4,289 $2.20 0 $0.00 0.00% \n\n"
+ " 284641 lesbianlovertube.info 0 0 $0.00051 2.5 4,275 $2.18 0 $0.00 0.00% \n\n"
+ " 299734 adzgame.com 0 0 $0.00051 1.2 4,231 $2.15 0 $0.00 0.00% \n\n"
+ " 288450 webxtechno.com 0 0 $0.00051 1.4 4,174 $2.13 0 $0.00 0.00% \n\n"
+ " 302458 analfreaksxxx.com 0 0 $0.00051 2.4 3,784 $1.93 0 $0.00 0.00% \n\n"
+ " 252536 sometraf.com 0 0 $0.00051 3.4 3,506 $1.79 0 $0.00 0.00% \n\n"
+ " 299656 pornolity.com 0 0 $0.00051 4.6 2,637 $1.35 0 $0.00 0.00% \n\n"
+ " 315438 coupononlinez.com 0 0 $0.00051 1.2 2,525 $1.28 0 $0.00 0.00% \n\n"
+ " 289861 mybestclick.net 0 0 $0.00051 1.1 2,474 $1.27 0 $0.00 0.00% \n\n"
+ " 309833 androtify.com 0 0 $0.00050 4.6 2,060 $1.04 0 $0.00 0.00% \n\n"
+ " 311942 thiendi596.weebly.com 0 0 $0.00051 3.3 1,910 $0.97 0 $0.00 0.00% \n\n"
+ " 289288 spornotube.com 0 0 $0.00051 4.3 1,908 $0.97 0 $0.00 0.00% \n\n"
+ " 302135 adjux.com 0 0 $0.00051 1.0 1,503 $0.77 0 $0.00 0.00% \n\n"
+ " 283047 pornhu.org 0 0 $0.00051 3.8 1,368 $0.70 0 $0.00 0.00% \n\n"
+ " 281818 adult.clicksocean.com 0 0 $0.00051 1.2 1,338 $0.68 0 $0.00 0.00% \n\n"
+ " 49001 seemyporn.com 0 0 $0.00051 7.5 1,269 $0.65 0 $0.00 0.00% \n\n"
+ " 1682 swapsmut.com 0 0 $0.00052 5.0 1,168 $0.60 0 $0.00 0.00% \n\n"
+ " 272422 adservme.com 0 0 $0.00051 1.1 1,119 $0.58 0 $0.00 0.00% \n\n"
+ " 189998 marketnews365.com 0 0 $0.00051 3.4 1,134 $0.57 0 $0.00 0.00% \n\n"
+ " 314783 startmedone.weebly.com 0 0 $0.00051 3.4 975 $0.50 0 $0.00 0.00% \n\n"
+ " 188823 teaser-popup.tk 0 0 $0.00051 2.3 969 $0.49 0 $0.00 0.00% \n\n"
+ " 309078 fotospornos.xyz 0 0 $0.00051 2.1 964 $0.49 0 $0.00 0.00% \n\n"
+ " 302044 hohovideos.com 0 0 $0.00051 3.5 871 $0.44 0 $0.00 0.00% \n\n"
+ " 293252 famteen.net 0 0 $0.00051 4.0 834 $0.42 0 $0.00 0.00% \n\n"
+ " 288476 forasweeterlife.com 0 0 $0.00051 3.5 794 $0.40 0 $0.00 0.00% \n\n"
+ " 292907 clickcpm.com 0 0 $0.00051 4.7 747 $0.38 0 $0.00 0.00% \n\n"
+ " 286107 dlsear.com 0 0 $0.00051 4.1 693 $0.35 0 $0.00 0.00% \n\n"
+ " 290437 amf.land 0 0 $0.00051 4.3 687 $0.35 0 $0.00 0.00% \n\n"
+ " 315021 xvideo1372.blogspot.com 0 0 $0.00051 4.4 664 $0.34 0 $0.00 0.00% \n\n"
+ " 307100 popvertising.com 0 0 $0.00050 3.2 643 $0.32 0 $0.00 0.00% \n\n"
+ " 33072 sweetteengirls.com 0 0 $0.00051 9.1 623 $0.32 0 $0.00 0.00% \n\n"
+ " 314516 nude-hot-girls.000webhostapp.com 0 0 $0.00051 5.1 613 $0.31 0 $0.00 0.00% \n\n"
+ " 191853 tumbex.com 0 0 $0.00051 5.8 587 $0.30 0 $0.00 0.00% \n\n"
+ " 300628 ts.adspyglass.com 0 0 $0.00052 1.7 574 $0.30 0 $0.00 0.00% \n\n"
+ " 310053 clickadunew.com 0 0 $0.00051 2.6 551 $0.28 0 $0.00 0.00% \n\n"
+ " 303397 zmakemoneyonline2017z.blogspot.com 0 0 $0.00051 3.4 485 $0.25 0 $0.00 0.00% \n\n"
+ " 314971 girlxdoo.blogspot.com 0 0 $0.00051 3.4 481 $0.25 0 $0.00 0.00% \n\n"
+ " 16042 pornburger.com 0 0 $0.00052 6.2 468 $0.24 0 $0.00 0.00% \n\n"
+ " 162942 reblop.com 0 0 $0.00051 4.9 470 $0.24 0 $0.00 0.00% \n\n"
+ " 293116 amateurspyporn.com 0 0 $0.00051 3.5 463 $0.24 0 $0.00 0.00% \n\n"
+ " 144611 vip-babes.com 0 0 $0.00051 3.9 462 $0.24 0 $0.00 0.00% \n\n"
+ " 269937 pinvert.porndoo.com 0 0 $0.00051 3.2 455 $0.23 0 $0.00 0.00% \n\n"
+ " 314970 toplady18.blogspot.com 0 0 $0.00051 3.3 456 $0.23 0 $0.00 0.00% \n\n"
+ " 75990 imgdrive.net 0 0 $0.00051 3.6 457 $0.23 0 $0.00 0.00% \n\n"
+ " 303109 adulthustlers.com 0 0 $0.00051 3.8 451 $0.23 0 $0.00 0.00% \n\n"
+ " 23147 siska.tv 0 0 $0.00051 4.4 443 $0.23 0 $0.00 0.00% \n\n"
+ " 313580 fumbleuporn.com 0 0 $0.00051 3.6 437 $0.22 0 $0.00 0.00% \n\n"
+ " 246025 myhotzpic.com 0 0 $0.00051 6.0 435 $0.22 0 $0.00 0.00% \n\n"
+ " 314969 love3xus.blogspot.com 0 0 $0.00051 3.3 431 $0.22 0 $0.00 0.00% \n\n"
+ " 307036 gotofm2018.blogspot.com 0 0 $0.00051 3.3 421 $0.21 0 $0.00 0.00% \n\n"
+ " 299241 filmepealese.com 0 0 $0.00051 3.9 416 $0.21 0 $0.00 0.00% \n\n"
+ " 93984 popmyads.com 0 0 $0.00051 5.0 415 $0.21 0 $0.00 0.00% \n\n"
+ " 299934 celebrity-leaks.net 0 0 $0.00052 4.7 410 $0.21 0 $0.00 0.00% \n\n"
+ " 314968 celebrities200x.blogspot.com 0 0 $0.00051 3.3 410 $0.21 0 $0.00 0.00% \n\n"
+ " 61235 poopeegirls.com 0 0 $0.00051 5.9 402 $0.21 0 $0.00 0.00% \n\n"
+ " 303804 pornorexia.com 0 0 $0.00051 3.8 401 $0.21 0 $0.00 0.00% \n\n"
+ " 51415 milfs-gone-wild.com 0 0 $0.00051 5.2 387 $0.20 0 $0.00 0.00% \n\n"
+ " 311683 ddxmiam.blogspot.com 0 0 $0.00051 3.3 389 $0.20 0 $0.00 0.00% \n\n"
+ " 153976 xxxhost.me 0 0 $0.00051 4.6 388 $0.20 0 $0.00 0.00% \n\n"
+ " 303808 hdporn24.com 0 0 $0.00051 3.8 385 $0.20 0 $0.00 0.00% \n\n"
+ " 189310 theblessedcouponer.com 0 0 $0.00051 3.9 383 $0.20 0 $0.00 0.00% \n\n"
+ " 175272 xxxporndigest.com 0 0 $0.00051 3.9 381 $0.19 0 $0.00 0.00% \n\n"
+ " 285389 thepornostars.com 0 0 $0.00051 3.6 364 $0.18 0 $0.00 0.00% \n\n"
+ " 293118 valuedgirls.com 0 0 $0.00051 3.4 354 $0.18 0 $0.00 0.00% \n\n"
+ " 294699 flurryad.com 0 0 $0.00050 1.3 343 $0.17 0 $0.00 0.00% \n\n"
+ " 43192 sextubehd.xxx 0 0 $0.00051 4.7 334 $0.17 0 $0.00 0.00% \n\n"
+ " 128468 amateursbf.skn1.com 0 0 $0.00051 4.2 332 $0.17 0 $0.00 0.00% \n\n"
+ " 255767 aneroticstory.com 0 0 $0.00052 4.6 315 $0.16 0 $0.00 0.00% \n\n"
+ " 299562 nudistsamateurpics.com 0 0 $0.00052 4.0 307 $0.16 0 $0.00 0.00% \n\n"
+ " 301912 teen-18-porn.com 0 0 $0.00052 4.0 305 $0.16 0 $0.00 0.00% \n\n"
+ " 268453 globaladmedia.com 0 0 $0.00051 1.2 304 $0.16 0 $0.00 0.00% \n\n"
+ " 133743 gaysexvideoo.com 0 0 $0.00051 4.2 297 $0.15 0 $0.00 0.00% \n\n"
+ " 139881 ezmob.com 0 0 $0.00052 1.0 288 $0.15 0 $0.00 0.00% \n\n"
+ " 15199 qrrro.com 0 0 $0.00051 4.0 292 $0.15 0 $0.00 0.00% \n\n"
+ " 307007 6996x.com 0 0 $0.00051 4.7 286 $0.15 0 $0.00 0.00% \n\n"
+ " 315277 xnxx690.tk 0 0 $0.00051 2.3 285 $0.14 0 $0.00 0.00% \n\n"
+ " 307063 linaxxx.com 0 0 $0.00051 6.3 275 $0.14 0 $0.00 0.00%\n"
+ " 168632 fullhdxxx.com 0 0 $0.00051 8.7 261 $0.13 0 $0.00 0.00% \n\n"
+ " 300385 sexvideostop.com 0 0 $0.00051 4.2 261 $0.13 0 $0.00 0.00% \n\n"
+ " 312006 curvyhdsex.com 0 0 $0.00051 4.3 263 $0.13 0 $0.00 0.00% \n\n"
+ " 303902 69pro.net 0 0 $0.00051 4.7 255 $0.13 0 $0.00 0.00% \n\n"
+ " 303392 sexzarja.eu 0 0 $0.00051 2.4 246 $0.13 0 $0.00 0.00% \n\n"
+ " 286395 maturesuperb.com 0 0 $0.00051 3.6 248 $0.13 0 $0.00 0.00% \n\n"
+ " 315212 sexyladyvideos.com 0 0 $0.00051 4.1 230 $0.12 0 $0.00 0.00% \n\n"
+ " 307981 sexyxvideos.com 0 0 $0.00051 4.2 219 $0.11 0 $0.00 0.00% \n\n"
+ " 32138 imgsin.com 0 0 $0.00051 4.7 215 $0.11 0 $0.00 0.00% \n\n"
+ " 225730 rutelki.com 0 0 $0.00051 3.3 215 $0.11 0 $0.00 0.00% \n\n"
+ " 234982 xxgasm.com 0 0 $0.00051 5.1 216 $0.11 0 $0.00 0.00% \n\n"
+ " 312029 hottubeclip.com 0 0 $0.00051 4.1 207 $0.11 0 $0.00 0.00% \n\n"
+ " 80965 lfporn.com 0 0 $0.00051 5.2 204 $0.10 0 $0.00 0.00% \n\n"
+ " 312451 hotxxxclip.com 0 0 $0.00051 4.0 205 $0.10 0 $0.00 0.00% \n\n"
+ " 97384 adult-xvideos.com 0 0 $0.00051 3.4 196 $0.10 0 $0.00 0.00% \n\n"
+ " 315008 sexygirlclips.com 0 0 $0.00051 4.2 199 $0.10 0 $0.00 0.00% \n\n"
+ " 31279 imgadult.com 0 0 $0.00051 3.8 194 $0.10 0 $0.00 0.00% \n\n"
+ " 301229 pinvert.fumeiti.com 0 0 $0.00050 3.9 195 $0.10 0 $0.00 0.00% \n\n"
+ " 295710 rtbfactory.com 0 0 $0.00051 1.0 186 $0.10 0 $0.00 0.00% \n\n"
+ " 288445 img4fap.com 0 0 $0.00051 5.3 185 $0.09 0 $0.00 0.00% \n\n"
+ " 295192 petiteamateurteen.com 0 0 $0.00051 3.6 186 $0.09 0 $0.00 0.00% \n\n"
+ " 305996 raipor.eu 0 0 $0.00051 3.9 181 $0.09 0 $0.00 0.00% \n\n"
+ " 297046 msaver.ru 0 0 $0.00052 3.5 174 $0.09 0 $0.00 0.00% \n\n"
+ " 80988 imgtaxi.com 0 0 $0.00051 4.0 170 $0.09 0 $0.00 0.00% \n\n"
+ " 98563 cuckporn.com 0 0 $0.00051 5.2 167 $0.09 0 $0.00 0.00% \n\n"
+ " 309148 mediaredirect.ru 0 0 $0.00051 4.8 168 $0.09 0 $0.00 0.00% \n\n"
+ " 313573 youadultporn.com 0 0 $0.00051 3.8 166 $0.09 0 $0.00 0.00% \n\n"
+ " 19573 youngpussyteen.com 0 0 $0.00051 8.1 165 $0.08 0 $0.00 0.00% \n\n"
+ " 106485 phicatube.net 0 0 $0.00051 4.1 166 $0.08 0 $0.00 0.00% \n\n"
+ " 284006 admeridian.com 0 0 $0.00051 1.0 164 $0.08 0 $0.00 0.00% \n\n"
+ " 308307 euporn.stream 0 0 $0.00051 5.4 163 $0.08 0 $0.00 0.00% \n\n"
+ " 244217 moresisek.com 0 0 $0.00051 4.6 159 $0.08 0 $0.00 0.00% \n\n"
+ " 283294 asiansgirls.info 0 0 $0.00050 3.5 157 $0.08 0 $0.00 0.00% \n\n"
+ " 306325 preteentop.pminor.com 0 0 $0.00051 4.8 153 $0.08 0 $0.00 0.00% \n\n"
+ " 293466 asianhotvidporn.us 0 0 $0.00050 3.4 153 $0.08 0 $0.00 0.00% \n\n"
+ " 285761 infinity-info.com 0 0 $0.00051 1.0 142 $0.07 0 $0.00 0.00% \n\n"
+ " 314575 youngpornvagina.ru 0 0 $0.00051 3.5 142 $0.07 0 $0.00 0.00% \n\n"
+ " 314777 scandalxxxvideos.com 0 0 $0.00051 3.8 142 $0.07 0 $0.00 0.00% \n\n"
+ " 19511 young-girl-porn.com 0 0 $0.00051 3.8 140 $0.07 0 $0.00 0.00% \n\n"
+ " 276919 jav911.com 0 0 $0.00051 4.9 138 $0.07 0 $0.00 0.00% \n\n"
+ " 75902 blobopics.biz 0 0 $0.00051 5.4 138 $0.07 0 $0.00 0.00% \n\n"
+ " 97473 tecnomectrani.com 0 0 $0.00051 4.5 134 $0.07 0 $0.00 0.00% \n\n"
+ " 303551 models.getxid.com 0 0 $0.00051 3.6 132 $0.07 0 $0.00 0.00% \n\n"
+ " 315135 4plugrush.blogspot.com 0 0 $0.00051 4.4 132 $0.07 0 $0.00 0.00% \n\n"
+ " 307519 redtubesexy.com 0 0 $0.00051 4.1 129 $0.07 0 $0.00 0.00% \n\n"
+ " 301259 sexcas.pw 0 0 $0.00051 3.8 125 $0.06 0 $0.00 0.00% \n\n"
+ " 302058 nudeamateurpicsxxx.com 0 0 $0.00051 4.3 125 $0.06 0 $0.00 0.00% \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}