// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[[^][]*]|"([^"]*)"|\S+"#).unwrap();
let string = "1.2.3.4 - - [02/Oct/2021:06:07:08 +0300 - -] 200 \"GET /index.php HTTP/2.0\" 6620 \"https://l.instagram.com/\" \"Mozilla/5.0 (Linux; Android 9; SM-N950F) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Mobile Safari/537.36\" \"-\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}