$re = '/^[A-Z]+[0-9][A-Z0-9]*[A-Z]$/m';
$str = 'A65AJ3L
A5
5A4
5AA
A5A
AAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);