$re = '/(?<![a-zA-Z])[a-z]*[A-Z][a-z]*[A-Z][A-Za-z]*(?![a-zA-Z])/m';
$str = 'But I\'m not sure how to select words like SElect, SeLeCt, SelecT, seleCT, selEcT.
Aselect';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);