$re = '/(?<=(<|>|=)\K=)/m';
$str = '5<Str+2&&Block>0||(7<=Dex&&8>=MHP)==2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);