package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)(?:(?:\.\.\/?)+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif|bmp|webp|pna|tiff|svg))`)
var str = `https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
src="../c624121/v624121992/3cf22/YRIx_w-QySg.png"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.jpg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.bmp"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.tiff"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.webp"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.pna"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.svg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.jpeg"
src="../c624121/v624121992/3cf22/YRIx_w-QySg.gif"
https://pp.vk.me/c624121/v624121992/3cf22/jpg/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.webp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.tiff
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.pna
https://pp.vk.me/c624121/v624121992/3cf22/svg/YRIx_w-QySg.svg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}