re = /^#(?:00(?:FF(?![fF]{2}|00)[a-fA-F0-9]{2}|(?![fF]{2}|00)[a-fA-F0-9]{2}FF)|FF(?:00(?![fF]{2}|00)[a-fA-F0-9]{2}|(?![fF]{2}|00)[a-fA-F0-9]{2}00)|(?![fF]{2}|00)[a-fA-F0-9]{2}(?:00FF|FF00))$/m
str = '#FF00AD
#00FFFD
#0023FF
#E300FF
#B4FF00
#FFCC00
#FF0000
#FFFFFF
#456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end