re = /"(?:\\.|[^"\\])*"/m
str = 'contractor:"Hi, this is \\"Paul\\", how are you?" client:"Hi ...."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end