import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<!\\b[01][0-9])(?<!\\b[2][0-3])([^\\S\\r\\n]*:)[^\\S\\r\\n]*(?![0-5][0-9](?:[ap]\\.?m\\b\\.?)?)";
final String string = "am\n"
+ "pm\n"
+ "P.M.\n"
+ "10:56pm : start a new line \n"
+ "10:43 a.m.";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}