use strict;
my $str = 'ABCŁąć1-2!Абв3§4“5def”';
my $regex = qr/[\W\d_]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";