$re = '/^(.*?), *((?:(?: *, *|$)?\bC\d+\w+)+)/m';
$str = 'Art, C13th, Italy
Art, C13th, C14th, Italy
Art, C13th, C14th, C15th, Italy
Art, C13th, C14th, Italy, Renaissance';
$subst = "$2, $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;