$re = '/(^|[^,\/])([0-9]*\.?[0-9]*)/';
$str = 'a 2 ana 1/2 are mere (55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);