re = /([\W\w]{10,}?)(\. )([\W\w]{200,}?)(\. )/m
str = 'Помогите, пожалуйста. с регуляркой или скриптом. Sed ut perspiciatis unde omnis iste natus error. sit voluptatem accusantium doloremque laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos qui ratione voluptatem sequi nesciunt. Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. Ut enim ad minima veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur? Quis autem vel eum iure reprehenderit qui in. ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem eum fugiat quo voluptas nulla pariatur?Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / 100 слов искать "точку с пробелом" и делать абзац. Помогите, пожалуйста, с регуляркой или скриптом. Помогите, пожалуйста, с регуляркой или скриптом. Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / 100 слов искать "точку с пробелом" и делать абзац. Помогите, пожалуйста, с регуляркой или скриптом. Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / 100 слов искать "точку с пробелом" и делать абзац. Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos qui ratione voluptatem sequi nesciunt. Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. Ut enim ad minima veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur? Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem eum fugiat quo voluptas nulla pariatur?Помогите, пожалуйста, с регуляркой или скриптом. Помогите, пожалуйста, с регуляркой или скриптом. Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / 100 слов искать "точку с пробелом" и делать абзац. Помогите, пожалуйста, с регуляркой или скриптом. Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos qui ratione voluptatem sequi nesciunt. Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. Ut enim ad minima veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur? Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem eum fugiat quo voluptas nulla pariatur? 100 слов искать "точку с пробелом" и делать абзац. -Помогите, пожалуйста, с регуляркой или скриптом. Помогите, пожалуйста, с регуляркой или скриптом. Необходимо в каждом файле поочередно через каждые 25 слов / 70 слов / 40 слов / 30 слов / 100 слов искать "точку с пробелом" и делать абзац.'
subst = '$1.\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result