$re = '/\s*<ListInventorySupplyResponse[\s\S]*?>[\s\S]*?<ListInventorySupplyResult[\s\S]*?>[\s\S]*?<MarketplaceId[\s\S]*?>[\s\S]*?<InventorySupplyList[\s\S]*?<ASIN[\s\S]*?>([\s\S]*?)<\/ASIN>/m';
$str = '<ListInventorySupplyResponse xmlns="http://mws.amazonaws.com/FulfillmentInventory/2010-10-01/">
<ListInventorySupplyResult>
<MarketplaceId>ATVPDKIKX0DER</MarketplaceId>
<InventorySupplyList>
<member>
<Condition>NewItem</Condition>
<SupplyDetail/>
<TotalSupplyQuantity>2</TotalSupplyQuantity>
<EarliestAvailability>
<TimepointType>Immediately</TimepointType>
</EarliestAvailability>
<FNSKU>X001WU2BYB</FNSKU>
<InStockSupplyQuantity>2</InStockSupplyQuantity>
<ASIN>B077NF427K</ASIN>
<SellerSKU>ASICS by Rakuten_20180926_29.86_6798</SellerSKU>
</member>
</InventorySupplyList>
</ListInventorySupplyResult>
<ResponseMetadata>
<RequestId>1fd9cdb3-2fad-47b3-878d-38581125cb18</RequestId>
</ResponseMetadata>
</ListInventorySupplyResponse>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);