$re = '/&.*?;/';
$str = 'There is a thing & righ here.;
There is a &and I don\'t know.;
Thjere is a & and a & here.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);