#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+|-]?(90.0{6}|[0-8]?[0-9].[0-9]{6})$"
Local $sString = "// Valid values" & @CRLF & _
                "" & @CRLF & _
                "-90.000000" & @CRLF & _
                "90.000000" & @CRLF & _
                "1.000000" & @CRLF & _
                "-1.000000" & @CRLF & _
                "9.999999" & @CRLF & _
                "88.888888" & @CRLF & _
                "77.777777" & @CRLF & _
                "66.666666" & @CRLF & _
                "55.555555" & @CRLF & _
                "44.444444" & @CRLF & _
                "33.333333" & @CRLF & _
                "22.222222" & @CRLF & _
                "11.111111" & @CRLF & _
                "00.000000" & @CRLF & _
                "-9.999999" & @CRLF & _
                "-88.888888" & @CRLF & _
                "-77.777777" & @CRLF & _
                "-66.666666" & @CRLF & _
                "-55.555555" & @CRLF & _
                "-44.444444" & @CRLF & _
                "-33.333333" & @CRLF & _
                "-22.222222" & @CRLF & _
                "-11.111111" & @CRLF & _
                "" & @CRLF & _
                "// Invalid values" & @CRLF & _
                "" & @CRLF & _
                "-90.000001" & @CRLF & _
                "-90.000010" & @CRLF & _
                "-90.000100" & @CRLF & _
                "-90.001000" & @CRLF & _
                "-90.010000" & @CRLF & _
                "-90.100000" & @CRLF & _
                "-91.000000" & @CRLF & _
                "90.000001" & @CRLF & _
                "90.000010" & @CRLF & _
                "90.000100" & @CRLF & _
                "90.001000" & @CRLF & _
                "90.010000" & @CRLF & _
                "90.100000" & @CRLF & _
                "91.000000" & @CRLF & _
                "+190.000000" & @CRLF & _
                "190.000000" & @CRLF & _
                "-190.000000" & @CRLF & _
                "-90.00000" & @CRLF & _
                "-90.0000" & @CRLF & _
                "-90.000" & @CRLF & _
                "-90.00" & @CRLF & _
                "-90.0" & @CRLF & _
                "-90." & @CRLF & _
                "-90" & @CRLF & _
                "-9" & @CRLF & _
                "190.000000" & @CRLF & _
                "90.00000" & @CRLF & _
                "90.0000" & @CRLF & _
                "90.000" & @CRLF & _
                "90.00" & @CRLF & _
                "90.0" & @CRLF & _
                "90." & @CRLF & _
                "90" & @CRLF & _
                "9" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")