package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bKA\b|\bKARNATAKA\b`)
var str = `KARNATAKA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}