re = /(^|[^"])(§\s*\d+)/m
str = '<href="§ 5"> asd
asdas § 5 asdas '
subst = '\\1§\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result