package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([\w]+)\b *(.*)?$`)
var str = `/command the arguments
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}