package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)attempt.+\sleft`)
var str = `Attempt(s) left`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}