package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bnot\b.*`)
var str = `He cannot go`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}