package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\r\n.!]*(?i)tel*[^\r\n]+`)
var str = `Testing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}