package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\W\d_]+|\d+`)
var str = `hello world123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}