$re = '/^(.+)\.(..)$/m';
$str = '123qseqwe.qw
qweqwe.qwe123
asdasd,as
asdasda.фы';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);