package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(?:www\.)?(?:m\.)?(?:youtu\.be\/|youtube\.com\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=))((\w|-){11})(?:\S+)?$`)
var str = `https://www.youtube.com/watch?v=12345678901
https://youtu.be/12345678901
https://youtu.be/12345678901?t=6
https://m.youtube.com/watch?v=12345678901&list=RD12345678901&start_radio=1=
https://www.youtube.com/watch?v=12345678901&list=RD12345678901&start_radio=1&rv=smKgVuS
https://www.youtube.com/watch?v=12345678901&list=RD12345678901&start_radio=1&rv=12345678901&t=38`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}