$re = '/\b\d{6}\b/m';
$str = 'teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);