package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:http[s]?:\/\/)?(?:[^\/\s]+)(?<path>\/.*)`)
var str = `https://www.gomage.com/
https://stage.gomage.com/magento-2-pwa/theme/pwa-features/
https://stage.gomage.com/magento-2-pwa/pwa-customization/
https://stage.gomage.com/magento-2-pwa/theme/
https://www.gomage.com/magento-2-pwa/pwa-theme.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}