$re = '/IsA[0-9]{1,4}Test/m';
$str = 'ThisIsA2018Test
IsA2018Test
IsNOTA2018Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);