$re = '/mailto:([^\"]+)/m';
$str = '<p><a href="mailto:info@tartaytantas.es"> info@tartaytantas.es</a></p>
<p>No cogemos pedidos por mail.</p>
<p></p>
</div><!-- .entry-content -->
<footer class="entry-footer">
</footer><!-- .entry-footer -->
</div>
</article><!-- #post-## -->
</main><!-- #main -->
</div><!-- #primary -->
</div></div>
<footer id="colophon" class="site-footer" role="contentinfo" itemscope="" itemtype="http://schema.org/WPFooter">
<div class="container">
<div class="footer-t">
<div class="row">
<div class="three-cols">
<div class="col">
</div>
<div class="col center">
<section class="widget widget_contact_form">
</section>
</div>
<div class="col">
</div>
</div>
</div>
</div>
<p><a href="mailto:info@tartaytantas.es"> info@tartaytantas.es</a></p>
<div class="site-info">
<span>
©2020 <a href="http://tartaytantas.es/">Tartaytantas - Tartas y bizccochos a domicilio en Aravaca</a>. </span>
Bakes and Cakes | Desarrollado por <a href="https://rarathemes.com/" rel="nofollow" target="_blank">
Rara Theme </a>
Funciona gracias a <a href="https://wordpress.org/">WordPress.</a>
</div><!-- .site-info -->
</div>
</footer><!-- #colophon -->
<div class="overlay"></div>
<a href="javascript:void(0);" class="btn-top"><span>Arriba</span></a>
</div><!-- #acc-content -->
</div><!-- #page -->
<script type="text/javascript" src="https://secureservercdn.net/160.153.137.170/zm5.b57.myftpupload.com/wp-content/themes/bakes-and-cakes/js/owl.carousel.min.js
javascriptvue.jsEdit tags
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);